System status

We continuously monitor the status of all of our systems. You can subscribe to updates to be notified of an outage and when service is restored.
Site experience minor issue
Incident Report for Gusto
Resolved
The issue has been mitigated
The fix has been rolled out to all Gusto users now, and we are monitoring the fix.
Posted Aug 04, 2020 - 18:53 PDT
Update
We're fixing an issue
We've investigated the problem and implemented a fix. It is on its way to all Gusto users now. ETA: 1 hour
Posted Aug 04, 2020 - 17:56 PDT
Investigating
We’ve found a problem with Gusto
We understand what’s gone wrong, and are working on a fix now.
Posted Aug 04, 2020 - 17:51 PDT
This incident affected: Payroll, Benefits, HR.