Customers are currently unable to access their Gusto accounts and Gusto mobile applications.
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Mar 25, 2021 - 17:18 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2021 - 16:48 PDT
Update
We are continuing to investigate this issue.
Posted Mar 25, 2021 - 16:37 PDT
Update
We are continuing to investigate this issue.
Posted Mar 25, 2021 - 16:36 PDT
Update
We are continuing to investigate this issue.
Posted Mar 25, 2021 - 16:36 PDT
Investigating
We’re investigating now.
We’ll keep this page updated as we fix the problem.
Posted Mar 25, 2021 - 16:35 PDT
This incident affected: Payroll, Benefits, HR and Gusto Mobile.