System status

We continuously monitor the status of all of our systems. You can subscribe to updates to be notified of an outage and when service is restored.
Customer Experience Site Slowness
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Jan 27, 2020 - 14:27 PST
Investigating
Some customers are experiencing site slowness and our engineers are investigating the root cause.
Posted Jan 27, 2020 - 13:58 PST
This incident affected: Payroll, Benefits, HR.