System status

We continuously monitor the status of all of our systems. You can subscribe to updates to be notified of an outage and when service is restored.
Dashboard slow to load
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Dec 16, 2019 - 11:48 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 16, 2019 - 11:42 PST
Update
We have begun the process of deploying code to resolve the issue. The issue is isolated to loading app.gusto.com, no backend systems powering payroll, benefits, or HR are impacted.
Posted Dec 16, 2019 - 10:43 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 16, 2019 - 10:38 PST
This incident affected: Payroll, Benefits, HR.