We are experiencing some disruptions to our phone service. In the meantime, please contact our support teams via chat or email.
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Sep 27, 2021 - 18:16 PDT
Update
We are currently investigating this issue and appreciate your patience.
Posted Sep 27, 2021 - 13:21 PDT
Investigating
We are currently investigating this issue and appreciate your patience.
Posted Sep 27, 2021 - 13:16 PDT
This incident affected: Phone System.