Some users may be experiencing issues loading their Gusto account
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Jan 24, 2022 - 11:24 PST
Investigating
We are currently investigating this issue.
Posted Jan 24, 2022 - 08:46 PST
This incident affected: Payroll, Benefits, HR.