Some users unable to log into their Gusto account using mobile devices
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Sep 20, 2022 - 08:05 PDT
Investigating
We are currently investigating this issue.
Posted Sep 20, 2022 - 06:51 PDT
This incident affected: Payroll, Benefits, HR.