Users may be experiencing issues with their Gusto Cash accounts.
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Apr 01, 2021 - 16:10 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2021 - 15:33 PDT
Investigating
We are currently investigating this issue.
Posted Apr 01, 2021 - 15:17 PDT
This incident affected: Gusto Mobile.