Customers may experience long wait times when generating reports.
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Sep 07, 2021 - 10:46 PDT
Investigating
We are currently investigating this issue.
Posted Sep 07, 2021 - 10:23 PDT
This incident affected: Payroll, Benefits, HR.