Degraded performance
Incident Report for Gusto
Resolved
A fix for the issue has been deployed.
Posted almost 2 years ago. Aug 10, 2017 - 14:39 PDT
Identified
We are currently seeing degraded performance in our payroll, benefits and HR product. We have identified the root-cause and are pushing a fix.
Posted almost 2 years ago. Aug 10, 2017 - 14:01 PDT