System status

We continuously monitor the status of all of our systems. You can subscribe to updates to be notified of an outage and when service is restored.
Customers are reporting issues with loading Gusto.com
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Jan 24, 2020 - 12:12 PST
Update
We are continuing to investigate this issue.
Posted Jan 24, 2020 - 12:12 PST
Investigating
We have not yet identified the cause for Gusto.com’s slow loading time. We are continuing to investigate.
Posted Jan 24, 2020 - 07:22 PST
This incident affected: Payroll, Benefits, HR.