System status

We continuously monitor the status of all of our systems. You can subscribe to updates to be notified of an outage and when service is restored.
Customer Experience Site Slowness
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Jan 21, 2020 - 11:27 PST
Update
We reverted the code that caused the slowness of the site. We’re seeing response times return to normal. We should be in the clear now.
Posted Jan 21, 2020 - 10:34 PST
Update
We’ve identified the code that is causing the slowdown for customers. We’re reverting the code to a previously known good state (ETA ~15min)
Posted Jan 21, 2020 - 10:23 PST
Investigating
We’ve identified the code that is causing the slowdown for customers. We’re reverting the code to a previously known good state. Will provide an ETA shortly
Posted Jan 21, 2020 - 10:17 PST
This incident affected: Payroll, Benefits, HR.