System status

We continuously monitor the status of all of our systems. You can subscribe to updates to be notified of an outage and when service is restored.
Some users unable to process payroll
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Sep 20, 2022 - 08:51 PDT
Investigating
We are currently investigating this issue.
Posted Sep 20, 2022 - 06:51 PDT
This incident affected: Payroll, Benefits, HR.