System status

We continuously monitor the status of all of our systems. You can subscribe to updates to be notified of an outage and when service is restored.
Site experience issue
Incident Report for Gusto
Resolved
We have resolved the issue and our site is back to stable.
Posted Aug 05, 2020 - 18:44 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 05, 2020 - 18:43 PDT
Identified
We're fixing an issue: we've identified the problem of signups being down and have implemented a fix. It's on its way to all Gusto users now
Posted Aug 05, 2020 - 17:29 PDT
This incident affected: Payroll, Benefits, HR.