System status

We continuously monitor the status of all of our systems. You can subscribe to updates to be notified of an outage and when service is restored.

Some users are unable to access or log into the Gusto website

Incident Report for Gusto

Resolved

This incident has been resolved.
Posted Nov 27, 2023 - 11:43 PST

Investigating

We are currently investigating this issue.
Posted Nov 27, 2023 - 10:45 PST
This incident affected: Gusto.com website.