System status

We continuously monitor the status of all of our systems. You can subscribe to updates to be notified of an outage and when service is restored.
Some customers may experience loading issues for reports and forms within their Gusto accounts due to an AWS outage.
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 15:16 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 28, 2022 - 12:44 PDT
Investigating
We are currently investigating this issue.
Posted Sep 28, 2022 - 10:41 PDT
This incident affected: Gusto.com website.