System status

We continuously monitor the status of all of our systems. You can subscribe to updates to be notified of an outage and when service is restored.
Customers are currently unable to view the "Tax Documents" tab within their Gusto account.
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 15:38 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 18, 2021 - 12:16 PST
This incident affected: Gusto.com website.