System status

We continuously monitor the status of all of our systems. You can subscribe to updates to be notified of an outage and when service is restored.
Customers are experiencing slowness and errors
Incident Report for Gusto
Resolved
Customers should no longer be experiencing slowness and errors in their Gusto dashboard.
Posted Nov 19, 2024 - 12:33 PST
Investigating
We are currently investigating an issue where customers are experiencing slowness and errors in their Gusto dashboard. This is also impacting the performance of our API.
Posted Nov 19, 2024 - 12:08 PST
This incident affected: Payroll, Benefits, HR and API.