System status

We continuously monitor the status of all of our systems. You can subscribe to updates to be notified of an outage and when service is restored.
Customers have reported an issue with Gusto
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Mar 03, 2020 - 13:18 PST
Investigating
We’ve investigated the problem and implemented a fix. It’s on its way to all Gusto users now.
Posted Mar 03, 2020 - 12:48 PST
This incident affected: Payroll, Benefits, HR.