System status

We continuously monitor the status of all of our systems. You can subscribe to updates to be notified of an outage and when service is restored.
Navigation issues
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Jan 17, 2020 - 09:22 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 17, 2020 - 09:18 PST
Investigating
We’re aware that some companies are not able to navigate within their Gusto account and our team is investigating this right now. We’ll keep you posted as we find a solution!
Posted Jan 17, 2020 - 08:47 PST
This incident affected: Gusto.com website and Payroll, Benefits, HR.