Some users may be experiencing issues accessing the "Benefits" tab of their Gusto account
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Sep 15, 2022 - 14:38 PDT
Update
We are continuing to investigate this issue.
Posted Sep 15, 2022 - 14:29 PDT
Investigating
We are currently investigating this issue.
Posted Sep 15, 2022 - 14:28 PDT
This incident affected: Gusto.com website and Payroll, Benefits, HR.