Gusto’s site is degraded
Incident Report for Gusto
Resolved
This incident has been resolved.
Posted Apr 19, 2020 - 15:07 PDT
Update
We are continuing to monitor for any further issues.
Posted Apr 19, 2020 - 15:04 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 19, 2020 - 15:01 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 19, 2020 - 14:54 PDT
Update
We are continuing to investigate this issue.
Posted Apr 19, 2020 - 14:09 PDT
Update
We are continuing to investigate this issue.
Posted Apr 19, 2020 - 10:27 PDT
Investigating
We’re investigating what’s wrong.
We’ll keep this page updated as we fix the problem.
Posted Apr 19, 2020 - 09:36 PDT
This incident affected: Gusto.com website.